Login  
 
0 vote

Par Planet Béninois le 31/07/2014 à 21:26 Voir l'article

Misc

Get privileges

router>enable
router#
Enter configuration mode

router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
router(config)#
Reset

router#copy flash:clean-config startup-config
router#reload
Configuration

router(config)#router

router(config)#show ip protocols
router(config)#show running-config
auto completion

Utiliser ? pour expand une commande
ex :
lab2-ro2621(config-if)#ip a?
access-group accounting address authentication
Voir le status des interfaces

router#show interfaces
Disable DNS resolution

router(config)#no ip domain-lookup
Cancel a traceroute

C-^

Supprimer toutes les routes

router(config)#no ip routing

Quitter proprement

M-A
(Alt shift A pour les non emacsiens)

Configuration des interfaces

Ethernet

router(config)#interface fastEthernet 0/0
router(config)#ip address 192.168.2.1 255.255.255.252 /* /30 */
router(config)#no shutdown

Loopback

router(config)#interface loopback ?
router(config)#ip address 192.168.2.1 255.255.255.252 /* /30 */
router(config)#no shutdown

Serie

/!\\ DTE a GAUCHE - DCE a DROITE/!\\
/!\\ Clock rate sur le s0/0 /!\\
router(config)#interface serial 0/0
router(config)#ip address 192.168.2.1 255.255.255.252 /* /30 */
router(config)#clock rate 1000000 /* Cote 0/0 seulement */
router(config)#encapsulation hdlc /* Cote 0/0 seulement */
router(config)#no shutdown

Routage

Route par defaut

router(config)#ip route 0.0.0.0 0.0.0.0
Ajouter une route statique

router(config)#ip routing
router(config)#ip route [distance]

RIP

V1 (classfull/ pas de ss reseau)

router(config)# router rip
router(config-router)# network
V2 (classless)

router(config)# router rip
/* Activation globale */
router(config-router)# version 2
/* Activation sur un network */
router(config-if)# ip rip send version 2
router(config-if)# ip rip reciev version 2
/* Ajouter ses networks */
router(config-if)# network
authentification

router(config)# key chain
router(config-keychain)# key
router(config-keychain-key)# key-string

router(config-if)#ip rip authentication key-chain
router(config-if)#ip rip authentication mode {text | md5}
router(config-router)# neighbor
router(config-router)# passive-interface serial 0/0

IGRP (classfull/pas de ss reseau)

router(config)# router igrp 1
router(config-router)# network

timer basic
Metric

M = (K1*bp + K2*bp/(256-charge) + K3 * delay) * (K5/(fiabilite + K4))
default K1 = K3 = 1 K2 = K4 = K5 = 0
router(config-if)# bandwidth <1-10000000>
router(config-if)# delay <1-16777215>
router(config-router)# metric weight 0 K1 K2 K3 K4 K5

repartition de charge

// rapartion entre les metric < metrique min * varaince
router(config-router)# maximum paths <1-6>
router(config-router)# variance <1-128>
router(config-router)# trafic-share balanced

VLAN

Static

creation

# vlan database
(vlan)# vlan name // vlan 1 = tout les prot par defaut ne pas utiliser
ajout port

router(config-if)# switchport acces vlan
management lan

router(config)# interface vlan
router(config-subif)# ip add x.x.x.x z.z.z.z
router(config-subif)# manegement //config le vtypour le telnet
affichage conf

show vlan brief

SECURITY PORT

router(config-if)# port security max-mac-count
router(config-if)# port security action shutnown
router(config-if)# end
#show port security

ETHERCHANNEL

router(config-if)# port group distribution destination
router(config-if)# no shutdown
// repeat on each interface of the group
# show etherchannel summary

ACL

numerotation(ip)

standard: 0-99 1300-1999
etendu 100-199 2000-2699
wildcard

mask de bit 0=checked 1=not checked
standard

a placer pres de la destination
router(config)# accesc-list {permit|deny}

etendues

a placer pres de la source
router(config)# access-list {permit|deny}
[established] [log]
protocol = ip | tcp | udp | icmp | ospf | igrp...
protocol = lt | gt | eq | neq

nomee

router(config)#ip access-list {standard|extended}
router(config-ext-nacl)# premit tcp
www

application

router(config-if)#ip access-group {in|out}

OSPF

Conf

router(config)#router ospf 4
router(config-router)#network 192.168.4.0 255.255.255.252 area 4
router(config-router)#area 4 authenticatio
router(config-if)#ip ospf hello-interval 5
router(config-if)#ip ospf dead-interval 20

Authentification

router(config-if)#ip ospf authentication-key toto